Skip to content

client lourd Nexcloud pour linux

Own-Nex-CloudSoftware - Progiciel

Installer le client Nextcloud pour Debian, il n'y a pas encore de package (.deb).

Avoir installer qt  du site ( le site Qt, voir l'installation), avoir les librairies : "libssl1.0-dev libqt5webkit5-dev qttools5-dev qttools5-dev-tools python-sphinx libinotifytools-dev texlive-latex-base libinotifytools-dev inotify-tools qt5keychain-dev qt5-default doxygen libnl-utils" (apt-get install libssl1.0-dev ...)

Si vous avez Qt déja installé via les package Debian pour pouvoir utiliser le Qt 5.7 ajouter dans votre ~/.bashrc la ligne  "export MAKE_PREFIX_PATH=/opt/Qt/5.7/gcc_64/lib/cmake/"

Choisissez un répertoire par example /srv puis cloner le git de nextcloud :

Récupération des sources

"git clone https://github.com/nextcloud/client_theming.git"

"git submodule update --init --recursive"

Compilation :

"mkdir mkdir build-1 build-linux" (si build-1 n'éxiste pas il y aura une erreur de compilation)

cd build-linux

"cmake -D OEM_THEME_DIR=`pwd`/../nextcloudtheme ../client"

"make -jx" (x = nombre de cores que vous voulez utiliser pour la compilation)

"make install"

"cp /usr/local/lib/x86_64-linux-gnu/libnextcloudsync.so.0 /usr/local/lib/x86_64-linux-gnu/nextcloud/" (du à un bug)

Rétroliens

Pas de rétroliens

Commentaires

Afficher les commentaires en Vue non groupée | Vue groupée

pra sur :

Pour les mises à jour faire un git pull puis un make clean
qmake make make install

Ajouter un commentaire

Marquer un texte en gras: *mot*, souligner un texte: _mot_.
Les smilies standard comme :-) et ;-) sont convertis en images.
Les adresses Email ne sont pas affichées, et sont seulement utilisées pour la communication.
Syntaxe BBCode autorisée
Form options